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1.0  Introduction

This Document describes the installation procedures necessary to configure and install Range Facility Management Support System (RFMSS) XXI on an SBIS multi-application Windows/NT server.  This is a living document and, as such, represents the present configuration agreed upon by the RFMSS Integrated Product Team (IPT).  It is understood that due to the incremental nature of the development effort, it is expected that adjustments to the Version Description Document (VDD) may be necessary. This document is subject to change and approval of any changes must be agreed to by the RFMSS IPT. 

2.0  Description

This VDD has been designed and organized with the following assumptions:


· Hardware and Software - Will be provided by the Army 

· Server  - A Microsoft Window NT single or dual processor 4.0 Server.  The server is assumed to have been loaded with the ISEC/ESSD golden master prior to performing the steps in this VDD.  

· Clients will be loaded with Windows 95 or Windows NT
 (with appropriate adapters, modems and client environment) .

· Clients’ userids and passwords will be set up on the Windows NT server and all users should be installed with the NT roaming profiles option.  Roaming profiles should be used to ensure that users have their G: drive mapped to the RFMSS server and that the RFMSS XXI shortcut appears on their desktop.

· If an NT Domain exists at the site (for example – Fort Sill or Fort Polk), a trust relationship must be set up so that users from the existing site domain can be copied into the RFMSS Group on the NT server. The site DOIM and ANSOC must determine the type of trust established.

3.0  Sharing Resources  on Server – G Drive

1) Right-Click on Start button

2) Click on Explore
3) Right-Click on drive G in the left pane of the Explorer

4) Select sharing

5) Select New Share (do NOT modify the existing G$ share)

6) Assign the Share Name of G to the G Drive
7) Click on Permissions.  Highlight  Everyone and click Remove.  Click Add.  Select the RFMSS group from the list of names presented and click Add.  From the pull-down list of permissions, select Full Control, and then click OK  

8) Click OK in the New Share window 

9) Click OK in the Properties window 

10) Click on File and then Close 
4.0  Installing Database

These installation procedures are performed on the RMFSS installed server.

1) Right click the Start button on the Task Bar.  Choose Explore.

2) Select the plus sign to the left of the d:\orant folder found in the left side of the Explorer window.

3) Select d:\orant\database folder.

4) From the menu, select File(New(Folder.  A new folder will appear in the right hand side of the Explorer window.  Name the folder, RFMSS.

5) On the left side of the Explorer window, select the CD ROM drive.  On the right side, select both of the following files and drag and drop them into the d:\orant\database\rfmss folder.

initRFMS.ora 

sysrfmss.dbf 

6) Click the Start button on the Task Bar. 

7) Select Programs, then Oracle for Windows NT, then NT Instance Manager
8) On the Instance Manager Window click the New button

9) In the New Instance Window enter the following information:

· SID:
RFMS

· DBA Authorization Password:
oracle

· Confirm DBA Authorization Password:
oracle

· Maximum Number of DBA/Operators:
5 (default)

· Ensure that the Services and Instances check boxes are both checked 

· Select Automatic startup mode 

· In the Parameter Initialization Filename text box, enter the file name d:\orant\database\initrfms.ora
9) Select Advanced button

10) In the Advanced Parameters- Database Creation window:

· Change the database name to RFMS
· In the LOGFILE and DATAFILE text boxes, replace all instances of h:\cots\orant.. with the string d:\orant..  (Logfile has two entries on the same line; change both.)

· Leave all other parameters at their default state 

· Click on the OK button 

11) In the New Instance window, click on the OK button.  This process will take a few minutes while the instance is started.

12) Click Cancel on the next message that comes up

13) In the Instance Manager window, click the Close button 

14) Reboot the machine.

15) Log back on as the administrator.

16) Open a DOS window by selecting Start, then Program, then Command Prompt
17) In the DOS window:

· type D: , then hit enter

· type cd orant\database\rfmss , then hit enter

· type set ORACLE_SID=RFMS, then hit enter

· type svrmgr23, then hit enter

· type connect internal/oracle, then hit enter

· type shutdown, then hit enter

· type exit, then hit enter

· type  del *.*, then hit enter

· when prompted are you sure <y/n>, reply 'y'

· Type exit to exit from the DOS window 

17) Open an Explorer window by right clicking on the Start button and selecting Explore. Click on View, Options, then select Show All Files.  Click OK.

18) In Explorer, select all of the files under the CD_ROM:\rfmss subdirectory of the CD-ROM.   Drag these file to the  D:\orant\database\rfmss subdirectory.

19) In Explorer, select all of the files under the d:\orant\database\rfmss subdirectory.  This can be done by opening the d:\orant\database\rfmss folder and using the key combination [Control] [a].  Select File/Properties (or right-click on the selected files) and clear the read-only and archive attributes for the files 
20) Close all open windows 

21) Click Start (Program( Oracle for Windows NT ( SQL*Net Easy Configuration
· Choose Add Database Alias radio box and click OK 
· Type RFMS in Choose Database Alias Window and Click OK

· Choose TCP/IP radio box and click OK in Choose Protocol Window

· Type either IP address or the Host name (for that site) in TCP/IP Host Name box. (depends on how your server is setup)

· Type RFMS in Database Instance Box

· Click OK

· Click on YES

· Choose exit SQL *NET Easy configuration radio box and click OK to quit 

· Click OK

22) Click Start ( Run and enter the command Notepad, then press [Enter]

23) Click File ( open and type in the name H:\cots\orant\network\admin\listener.ora

24) Near the bottom of the file is a section that defines the SID list for the listener.  In its original form it should appear like this:

SID_LIST_LISTENER =


(SID_LIST =



(SID_DESC =




(SID_NAME = ORCL)



)


)
This section must be modified to make Oracle listen for a database instance named RFMS  created earlier and for a database instance named RT00 that will be created later.  To do this, select and copy the following three lines:  (Ensure that the entire entry is copied, including all parentheses.)



(SID_DESC =




(SID_NAME = ORCL)



)

Paste the three lines below the lines shown above.   Replace the first ORCL with RFMS and the second ORCL with RT00 so the section looks like this:

SID_LIST_LISTENER =


(SID_LIST =



(SID_DESC =




(SID_NAME = RFMS)



)



(SID_DESC =




(SID_NAME = RT00)



)


)
The spaces around the = signs should not be eliminated 

If there are multiple instances of Oracle databases on the server, each will have its own SID_DESC section.  You must preserve the correct structure of this file, as shown below:

SID_LIST_LISTENER =


(SID_LIST =



(SID_DESC =




(SID_NAME = IRPR)



)



(SID_DESC =




(SID_NAME = RFMS)



)



(SID_DESC =




(SID_NAME = RT00)



)



(SID_DESC =




(SID_NAME = HSMS)



)


)
After editing the file to correctly reflect the presence of the RFMS instance and the later addition of RT00, save the file and exit from Notepad 

25) Reboot the computer. 

26) Log on as administrator; Test the connection by doing the following steps: 

· From start ( program ( Oracle for windows NT, click on SQL Plus 3.3 
· Type user name and assigned password

· Type rfms on Host String Box 

· You should be able log into the RFMS Database (Access to training database will be tested later) 

A SQL> prompt should appear in the Plus 3.3 window.

5.0  Installing the Arc View Patch to ArcView 3.0a

This patch needs to be installed on the server and every remote client machine that has a copy of ArcView.   
1) Double click on the AVDLOG application (will this be on the RFMSS Server Installation CD-ROM).  Location, CD_ROM:\application\gis
2) There will be a prompt asking if you want to install the ArcView Dialog Designer.  Click on yes 

3) Click Next on the first screen 

4) Select Administrative Network Install and click Next.  Use Administrative Network install for the Range Control installation 

5) Select Typical on the Installation Options Screen and then click on the Browse button to change the directory specifying where ArcView is to be loaded.  On the Choose Directory screen, input H:\COTS\Arcview\  to load ArcView Patch on H drive of server. Then click on the OK button 

6) Click Next on the Program Folder Screen 

7) Click Finish on the Settings Screen to start copying files  

8) Deselect the prompt to view the readme.txt and then click Finish
9) Click OK at Information window

10) Double click on My Computer
11) Double click on the h: drive  

12) Double click on the h:\cots folder

13) Right click on the Arcview folder

14) Click on Rename; change the name of the ARCVIEW folder to ESRI

15) On the warning message, click OK
6.0  Creating Users Accounts on the Domain Controller

User Accounts will need to be added to the Server to allow users access to the NT Domain.  (SBIS user account needs to be submitted to ANSOL.  Approval is required to ass a user.)  

1) Click on Start button.

2) Click on Programs.
3) Click on Administrative Tools.

4) Click on User Manager.

5) Select under User Menu Option, select new user.

6) Enter the appropriate information (name and password).  Ensure the user is added to the RFMSS local group.
7) If the user account to be added is to be used on a Windows 95 machine, select - password never expires. If the user account to be added is on a Windows NT machine, then select -user must change password at next logon 

8) Then click on add 

9) Then click on exit to end adding user accounts in domain 

10) NOTE:
Add the userid support and password 12SUpport for remote site dial up capability.   This userid must have administrator authority and must also be a member of the RFMSS Group.  Password never expires must be selected for this userid.

11) NOTE:
Add the userid training and password 12TRaining for training database set up capability.  This userid must be a member of the RFMSS Group. Password never expires must be selected for this userid.

7.0  Copying Files from Server Installation CD

1) Copy the H:\COTS\ESRI folder to the G Drive. 

2) Insert RFMSS Server Installation CD-ROM into the CD-ROM Drive. 

3) Double click on My Computer and double click on CD-ROM Drive.

4) Select the Application folder and copy the files listed below to the G: drive on the server: 

· Pwrs

· Rfmss40

· Users Manual

5) Select the Application\GIS folder and copy the following files the the G: drive of the server:

· Avfiles

· Gisdata

6) Copy the following files from the Server installation CD-ROM Avfiles folder to the G: drive:

· Avdlog.exe

· Banner.bmp

NOTE: When copying files over from CD-ROM, make sure that under the properties for the file, the attributes read-only and archive are deselected.  On the server G: drive in Explorer, select all the files by opening each folder and using pressing [Control] [a].  From the menu, choose File(Properties.  De-select Read Only and Archive Attributes.

8.0  Setting up GIS folders and files and setting Event Log Options on the server

8.1  Setting up GIS folders and files on the server

1) Using Explorer, move the G:\avfiles folder and all of its contents into G:\esri folder to create G:\esri\avfiles folder 

2) Move the startup file from G:\esri\avfiles folder to G:\esri\Av_gis30\Arcview\Etc 

3) Move the banner.bmp file from G:\esri\avfiles folder to G:\esri\Av_gis30\Arcview\Etc 

4) Click on START; Click on RUN, type notepad and click OK 
5) Open the file G:\RFMSS40\RFMSS40.ini
6) Make sure the paths are as follows:

[GIS]

SERVER_NAME=

ESRI_NAME= G:\ESRI\AV_GIS30\BIN32\ARCVIEW.EXE

PROJ_1= G:\ESRI\AVFILES\AVPROJECTS\OPERATIONS.APR

PROJ_2= G:\ESRI\AVFILES\AVPROJECTS\MIMS.APR

PROJ_3= 

PROJ_4= 

PROJ_5= 

PROJ_6= 

PROJ_7= 

PROJ_8= 

PROJ_9= 

PROJ_10= 

PROJ_FD= G:\ESRI\AVFILES\AVPROJECTS\OPERATIONS.APR

PROJ_MIMS= G:\ESRI\AVFILES\AVPROJECTS\MIMS.APR 

RFMSS_NAME=G:\ESRI\AVFILES\AVPROJECTS\OPERATIONS.APR

SERVER_GIS= G:\ESRI\AVFILES\FTGISDAT

LOCAL_GIS=C:\GISDATA

NOTE: Generally, these values will be updated by the GIS installers and do not need to be edited at this time.


UTM_ZONE = 


MIL_GRID_PRE = 


DATUM = 

UTM_ZONE can be obtained from the 1:50,000 DMA Installation Map.  Look for the box in the Center of the Map Legend.  The UTM zone is in a box with the Identification Grid Zone Designation.  The Zone is only the numeric portion of the designation 

MIL_GRID_PRE is a combination of the values in the Grid Zone Designation box and the 100,000 M. SQUARE IDENTIFICATION boxes.  If there is more than one value in the 100,000 M. ID box, choose one 

DATUM can be obtained from the 1:50,000 DMA Installation Map.  In the Lines of text above the boxes where you found the values for the UTM_ZONE and MIL_GRID_PRE, look for a value following the keyword ELLIPSOID or GRID.  Valid values for this will be either WGS84 (World Geodetic System 1984) or CLARKE1866 (Clarke 1866).

7) Save changes.

8) Exit Notepad.

9) The server is now fully configured and ready for use. 

8.2  Setting Event Log Options on the server

1) Click on Start.

2) Click on Programs.

3) Select Administrators Tools and select Event Viewer.

4) Click on Log, and Log Settings.

5) There are three logs that may be set:  Security, System, and Application.  For each log, select either Overwrite events as needed, or Overwrite events older than      days.  The range is from one (1) to 365 days.  The default size of the event log is 512K and as needed when full will overwrite events that are older than 7 days.

9.0  Oracle Client Installation

9.1  Oracle Client Installation on NT Workstations – LAN Connected    

1) Close out initial Welcome to Windows NT Screen and insert Oracle Server CD-ROM.  This will auto-start the Oracle7 installation process 

2) Load Oracle7 Software for Windows NT by clicking on Yes 

3) The language should be set to English. Click the OK button 

4) Enter the Company name and accept the default destination for the Oracle software.   Click the OK button.  Oracle will close.

5) A notice may appear that begins with reboot for path update…c:\orant\bin etc.,  reply Yes.  
6) Double click My Computer.  Double click on the CD-ROM drive. By doing so, you will start Oracle again.  Repeat the process beginning with step 2.

7) At next screen, select Oracle7 Client Products and then click the OK button. 

8) At type of Install, select Application User.

9) At the document storage prompt, select CD-ROM IF YOU DON’T WANT THE HELP DOCUMANTATION.

10) Once completed, then click on the OK button to end loading Oracle7 Client software. 

11) From the SBIS PC Baseline CD ROM, go to CLINT733\NT_X86\V7\RSF72 folder, and copy the OCIW32.DLL file to the C:\ORANT\BIN directory.  The system will ask if you want to replace the existing file.  Enter Yes.

12) Reboot the PC and sign back on with appropriate userid.

13) Click on start button, then select programs, then Oracle for Windows NT and then Select 32-Bit Administrator.
14) Choose the system DSN tab.

15) Click on add and select Oracle73 and then click on Finish.  (This will automatically bring up a pop up screen called ODBC Setup screen).

16) On the ODBC Setup screen, enter the following (necessary for client access to Arcview/GIS data): 

Data Source Name  - rfmss40
Description – RFMSS XXI Application

SQL*Net Connect String – rfmss40
17) Click the OK button and then click on OK to close 

18) Click on start button, then select programs, then Oracle for Windows NT
19) Select SQL*Net Easy Configuration 

20) Select Add a database Alias, Click OK button

21) Enter  rfmss40 as the database alias and then click on OK button 

22) Select TCP/IP and then click the OK button. TCP/IP Host Name – should be the computer name of the database server machine. This should be referenced from the Setup Checklist. (The SBIS server convention is Fs71550 where 1550 is the server building number.)

23) Database Instance – should be RFMS
24) Click OK, 

25) Validate the information, Click yes
26) Click on Exit SQL*Net Easy Configuration.  Click OK. 

27) Click OK for the next two screens.

28) Click on Start button and select Run. 

29) Type sysedit in the run dialog box. 

30) Select the c:\winnt\win.ini file. 

31) At the bottom of the file, type the following two lines


[profile rfmss40]

profile_name = g:\ rfmss40\rfmss40.ini
32) Select autoexec.bat and add the following line, Path=g:\pwrs\pb5i32dk;  Note: If a path statement exists, add the ;g:\pwrs\pb5i32dk  after the last entry statement.  For example, Path=c:\windows;c:\windows\dos;g:\pwrs\pb5i32dk;
33) Click File(Exit(Yes to save the changes. 

34) Right click  on Network Neighborhood and click on Map network drive
35) Select drive letter G
36) Scroll down the shared directories list and find the name of your server. Double click the server name CAR-SBIS IS THE DOMAIN. The SBIS server convention is Fs71550 where 1550is the server building number.

37) Click on the server share named G to highlight it.

38) Select reconnect at log on. 

39) Click OK
40) From the G drive, double click on the rfmss40 folder. In this folder is the executable rfmssxxi.exe file. Click, hold, and drag and drop into the desktop window.

41) Shut down and restart computer and sign back on to use the RFMSS XXI Application.  Continue to section 10.0 to setup Arcview for the workstation. 

9.2  Oracle Client Installation on Win95 Workstations – LAN Connected   

1) Close out initial Welcome to Windows 95 Screen and insert Oracle Server CD-ROM.  This will auto-start the Oracle7 installation process 

2) Load Oracle7 Software for Windows 95 by clicking on Yes 

3) The language should be set to English.  Click the OK button 

4) Enter the Company name and accept the default destination directory where the Oracle software will be loaded. Click the OK button

5) There may be a notification about adding ORAWIN95\BIN to the PATH variable in your AUTOEXEC.BAT file. If so, click OK.

6) At next screen, select Oracle7 Client Products and then click the OK button 

7) At type of Install, select Application User 

8) At the document storage prompt, select CD-ROM IF YOU DON’T WANT THE HELP DOCUMENTATION.

9) Once completed, then click on the OK button to end loading Oracle7 Client software 

10) Reboot the PC and sign back on with appropriate userid.

11) Click on start button, then select programs, then Oracle for Windows 95 and then select 32-Bit Administrator
12) Click on add and select Oracle73 and then click on Finish. (This will automatically bring up a pop up screen called ODBC Setup screen)
13) On the ODBC Setup screen, then enter the following (necessary for client access to Arcview/GIS data): 

Data Source Name  - rfmss40
Description – RFMSS XXI Application

SQL*Net Connect String – rfmss40
14) Click the OK button and then click on OK to close 

15) Click on start button, then select programs, then Oracle for Windows NT
16) Select SQL*Net Easy Configuration 

17) Select Add a database Alias, Click OK button

18) Enter  rfmss40 as the database alias and then click on OK button 

19) Select TCP/IP and then click the OK button. TCP/IP Host Name – should be the computer name of the database server machine. This should be referenced from the Setup Checklist. CAR-SBIS IS THE DOMAIN (The SBIS server convention is Fs71550 where 1550 is the server building number.)

20) Database Instance – should be RFMS.
21) Click OK.

22) Validate the information, Click yes.
23) Click on Exit SQL*Net Easy Configuration.  Click OK. 

24) Click OK for the next two screens.

25) Click on Start button and then click Run. 

26) Type sysedit in the run dialog box.

27) Find the c::\windows\win.ini file. 

28) At the bottom of the file, type the following two lines

[profile rfmss40]

profile_name = g:\ rfmss40\rfmss40.ini
29) Select autoexec.bat and add the following line, Path=g:\pwrs\pb5i32dk;  Note: If a path statement exists, add the ;g:\pwrs\pb5i32dk  after the last entry statement.  For example, Path=c:\windows;c:\windows\dos;g:\pwrs\pb5i32dk;
30) Click FILE, EXIT, YES to save the changes 

31) Right click on Network Neighborhood and click on Map network drive.
32) Select drive letter G
33) Type the following in the path line: Fs71550.  (Where Fs71550 is the server number.)

34) Click on the server share named G to highlight it 

35) Select reconnect at logon.

36) Click OK
37) From the G Drive, double click on the rfmss40 folder. In this folder is the executable rfmssxxi.exe file. Click, hold, and drag and drop it to the desktop window. 

38) Shut down and restart computer and sign back on to use the RFMSS XXI Application. 

10.0  LAN Connected for NT and Windows 95 Client Workstation Setup for Arcview   

This procedure should be followed for every client requiring RFMSS graphic mode. 

1) Go to the G drive that should have been set up on the workstation and go to the G:\ESRI\AV_GIS30\AVSETUP directory and double click on the Setup Application 

2) Click Next at each screen and Finish on the last screen. This will install the correct font files and other necessary files on the client machine 

3) Click on the G drive.  Copy the gisdata folder  to C: drive of the client machine on root directory (C:\gisdata) 

The workstation install is now completed.  On the workstation, verify the following:

Display should be set to 1024x768 60 Hz.  Select Start(Settings(Control Panel(Display(Settings.  Change resolution settings to 1024x768.  Click OK.

Windows messaging should be turned on.  Go to Control Panel(Add/Remove Programs(Windows NT Setup.  Scroll down to the bottom of the list to Windows messaging.  Select Windows Messaging, double click on the box and select only windows messaging.  De-select the two mail options.  Click OK to copy files from  the Windows NT Workstation CD ROM.

Install Norton Anti-virus on each workstation.  This can be found on the SBIS CD ROM and SBIS instructions.  (This is usually performed by SBIS installation team.)

11.0  Remote Client Installation of RFMSS Application  (Windows 95) 

You will need approximately 23MB of disk space to install the RFMSS Application (excluding ArcView).  The software to be loaded should be the 32-bit version. 

The following steps need to be performed before using RFMSS XXI. Each step is described in detail below. It is recommended that you close all other applications before installing this product. 

All of the needed software (except ArcView) is included on the RFMSSXXI Remote Client CD or on the Windows 95/Windows NT installation disks or CD for the network drivers.   If installing  fully licensed ArcView, the RFMSSXXI server CD is also needed. 

This section covers these actions in step by step detail in order to install RFMSS:

· Modify your Network

· Install SQL*Net

· Configure SQL*Net

· Install ArcView (optional)

· Install RFMSS

· Configure the Dial-Up Networking

· Restart the machine

· Connect to the Range's network

· Start RFMSS

11.1 Modify your Network – Domain

1)  Click the Start button

2)  Click Settings

3)  Click Control Panel

4)  Double click Network

5)  Select the Configurations tab page. 

6)  Select Client for Microsoft Networks

7)  Click Properties

8)  Deselect Log on to Windows NT domain

9)  In the Windows NT Domain box, enter the name of your RFMSS domain

10)  Click OK.

11.2  Modify your Network - TCP/IP

Verify that TCP/IP is identified on the Network properties screen.  If not, consult your Windows 95/Windows NT documentation on how to install TCP/IP 

11.3  Install SQL*Net

1) Insert the CD into the drive

2) Click the Start button

3) Click Run   

4) Type D:\SQLNET\Setup where D: is the letter for your CD drive

5) Do you want to install Oracle Client for Windows 95?

6) Click the YES button

7) Select English
8) Click the OK button

9) Enter your unit's name (accept the default Oracle home as C:\ORWIN95)

10) Click the OK button. There may be a notification about adding ORAWIN95\BIN to the PATH variable in your AUTOEXEC.BAT file. If so, click yes 

11) Please select the type of installation you want to perform. Select Oracle 7 Client Product Install
12) Please select the type of Installation – Select Application User

13) Select Online Documentation to be located on CD-ROM
14) After all of the files are installed, confirm all of the dialogs and exit the Oracle installer

11.4  Configuring SQL*Net

1) Click the Start button

2) Click on Programs
3) Click on Oracle for Windows 95
4) Click on SQL*Net Easy Configuration. There may be a dialog labeled Missing SQLNET.ORA.  If so, click Yes.

5) Select Add Database Alias
6) Click the OK button

7) Type rfmss40 for the Database Alias

8) Click the OK button

9) Chose TCP/IP as the network protocol

10) Type the TCP/IP address for the data server ( 158.13.104.2). 

11) Type RFMS for the Database Instance

12) Click the OK button

13) Do you want to add this database alias

14) Click the Yes button

15) Select Exit SQL*Net Easy Configuration

16) Click the OK button

17) Exiting SQL*Net – Click the OK button

11.5  Install ArcView (optional)

1) Not every user will need the GIS component of RFMSS.  If you are not installing ArcView, skip to 11.6 Installing RFMSS.

2) Close all other programs 

3) Insert the ArcView CD in your drive. The ArcView install process should autostart.  If nothing happens, then press the Start button and select Run.  At the prompt, type in the command Z:\SETUP.EXE (where Z: is the drive letter of your CD-ROM drive) 

4) Press the Next button

5) Select Local Install and press the Next button

6) Select Custom and press the Next button.  If you change the destination directory by pressing the Browse button, you will need to alter the rfmss40.ini file later in 10.6 Installing RFMSS. Your destination directory will most likely be C:\ESRI 
7) Deselect the Map Data 

8) Press the Next button to create the program folder

9) Click Next 

10) Press the Finish button

11) After the files have loaded, press the OK button

12) Select Yes and press the Finish button to restart your machine 

IF YOUR COMPUTER HAS ARCVIEW INSTALLED, THE FOLLOWING STEPS MUST BE FOLLOWED TO INSTALL A NECESSARY PATCH TO THE APPLICATION 

1) Insert the RFMSS XXI server CD-ROM into your CD-ROM drive   

2) Using Explorer, double click on the AVDLOG application on that drive 

3) There will be a prompt asking if you want to install the ArcView Dialog Designer.  Click on yes 

4) Click Next on the first screen 

5) Select Local Install and click Next.  Use Local Install for Remote sites 

6) Select Typical on the Installation Options Screen and then click on Browse button to change the directory of where ArcView is to be loaded. On the Choose Directory screen , input C:\ESRI\ to load ArcView on the remote client. Then press on OK button 

7) Click Next on the Program Folder Screen 

8) Click Finish on the Settings Screen to start copying files  

11.6  Installing RFMSS

1) Insert the RFMSS CD in your drive

2) Click the Start button

3) Click Run
4) Type Z:\rfmss\setup where Z: is the drive letter for your CD

5) Click the OK button

6) On the first screen, select Install Products and click the Next button

7) Select 32-bit - short names and click the Next button

8) If you HAVE NOT purchased and installed the ArcView GIS software, perform the following steps:

· Select Typical and click the Next button

· Select RFMSS XXI and click the Next button

9) If you HAVE purchased and installed the ArcView GIS software, perform the following steps:

· Click on CUSTOM 

· Click Next

· Click Details
· Select GIS Support 
· Change the path from C:\rfmss\gisdata to C:\gisdata
· Select  GIS Startup
· Change the path to C:\esri\avi_gis30\arcview\etc if it is different 
· Click OK
· Click the Next button

10) Select Prompt for each (the first option) and click the Next button

11) Select Install Now and click the Next button

12) If this is the first install, you may be asked if you want the new directories created.  Click OK for these messages.

13) Close all other applications running on your machine, then click the OK button on the confirmation window 

14) Click on the Next button after the files have been loaded

15) If the window labeled Update initialization files appears, select Update Files and click the Next button

16) If the window labeled Create Program Group and Icons appears, select Yes and click the Next button

17) Click on the Finish button

18) If you changed the destination directory of the GIS in step 4, you need to modify a parameter in the RFMSS40.ini file

19) Click on START, Click on RUN, type notepad and click OK 
20) Open the file C:\RFMSS\RFMSS40.ini  The RFMSS40.ini can be printed from the G: drive and used as a guide while installing remote PCs.

21) Find the line that defines the value of ESRI_NAME.  This value must be changed to reflect the location of the executable on your system.  For example, if you have followed this VDD to install ArcView, then the line 

ESRI_NAME = G:\ESRI\AV_GIS30\ARCVIEW\BIN32\ARCVIEW.EXE

must be changed to

ERSI_NAME = C:\ESRI\AV_GIS30\ARCVIEW\BIN32\ARCVIEW.EXE 

22) Update the following lines (the values will possibly change from site to site) in the RFMSS40.ini file:


UTM_ZONE = 18


MIL_GRID_PRE = 18TVP


DATUM = WGS84

UTM_ZONE can be obtained from the 1:50,000 DMA Installation Map.  Look for the box in the center of the Map Legend.  The UTM zone is in a box with the Identification Grid Zone Designation.  The Zone is only the numeric portion of the designation 

MIL_GRID_PRE is a combination of the values in the Grid Zone Designation box and the 100,000 M. SQUARE IDENTIFICATION boxes.  If there is more than one value in the 100,000 M. ID box, choose one 

DATUM can be obtained from the 1:50,000 DMA Installation Map.  In the Lines of text above the boxes where you found the values for the UTM_ZONE and MIL_GRID_PRE, look for a value following the keyword ELLIPSOID or GRID.  Valid values for this will be either WGS84 (World Geodetic System 1984) or CLARKE1866 (Clarke 1866) 

23) Do not modify any other lines!
24) Copy the startup file from the Client CD-ROM to the C:\Esri\Av_gis30\Arcview\Etc\ folder 

25) Copy the banner file from the Client CD-ROM to the C:\Esri\Av_gis30\Arcview\Etc\ folder 

11.7  Configure the Dial-Up Networking

1) Double click the My Computer icon

2) Double click the Dial-Up Networking icon. (If there is no Dial-Up Networking icon, see the section 10.8 Installing Dial-Up Networking)

3) Double click the Make New Connection icon

4) A window labeled Make a New Connection will appear

5) Type RFMSS for the field labeled Type a name:

6) If you have more than one modem installed, select the modem you wish to use in the field labeled Select a modem:

7) Click the Next button

8) In the field labeled Telephone # enter the range's telephone number, including any prefixes needed to dial internal or external numbers   

9) Click the Next button

10) Click the Finish button

11) In the Dial-Up Networking window, a new icon will appear called RFMSS. If you would like to have this icon appear on the desktop then left-click on the icon and drag the icon onto our desktop 

12) A message will appear asking if you would like to create a shortcut 

13) Click the Yes button

14) Double click the  icon

11.8  Installing Dial-Up Networking

1) If your installation of Windows 95 does not contain Dial-Up Networking, then you will need to add it.  In order to do so, you will need to have the original CD-ROM or diskettes, which were used to install Windows 95 on your machine.

2) Double click the My Computer icon

3) Double click the Control Panel icon

4) Double click the Add/Remove Programs icon

5) Click on the Windows Setup tab

6) Deselect all of the Components except for Communications 

7) Click the Details button

8) Deselect all of the Components except for Dial-Up Networking 

9) Click the OK button

10) Click the OK button 

11) You will be prompted for the appropriate disk(s).  Insert them as they are called for 

12) When complete, you may be required to restart your system.

11.9   Restart the machine

 Close all programs and restart the machine 

11.10  Connect to the Range's network

1)
Double click the My Computer icon on your desktop

2)
Double click Dial-Up Networking
3)
Double click on the Dial-up icon that you created in step 6 above 

4)
Enter your userid and password

5)
Click the OK button

6)
Map your G: drive to the Range's G drive
(a)
Click the Start button

(b)
Click Programs
(c)
Click Windows Explorer
(d)
Click on the menu bar item Tools
(e)
Click on Map Network Drive
(f)
Select drive G:

(g)
For the path, type \\server-name\G where server-name is the name of your Range Control's server   

(h)
Click the OK button

11.11  Starting  RFMSS

1) Click on the Start button

2) Click on Programs
3) Click on RFMSS XXI (the folder)

4) Click on RFMSS XXI (the application)

Appendix A:  Setting up Roaming User Profiles on NT Server

Purpose:  Roaming profiles should be used to ensure that users have their G: drive mapped to the RFMSS server and that the RFMSS XXI shortcut appears on their desktop 

1) Log onto domain server as the domain administrator. As administrator, you will have access / the capability to create the profiles folder on the server.

2) Double click the My Computer icon on the desktop 

3) Double click the icon for the C: drive 

4) Select File>New>Folder. Type profiles as the name of the new folder 

5) Right click the profiles folder and select properties 

6) Select the Sharing tab and select the Shared As radio button.

7) Click the button labeled Permissions and make sure the Everyone group has Full Control
8) Select the Security Tab (If profiles directory is in an NTFS volume).

9) Click the button labeled Permissions 

10) Grant the Everyone group Full Control  

11) Click OK 

12) Click Start>Programs>Admin Tools Common>User Manager for Domains  

13) Double click desired user 

14) The User Properties box for that user will appear.  Click the button labeled profile 

15) Where it says User Profile Path, type \\servername\profiles\%username%  where servername is the name of the server with the C:\profiles directory.  Username is the name of the specific user for whom you are creating the profile   
16) Click OK, which will close the User Environment Profile box 
17) Click OK again, which will close the User Properties box 
18) Repeat steps 13 - 17 for all subsequent users that need roaming profiles 
19) In User Manager for Domains, select Users>Exit.  Then log off  the server 
20) For Newly created users follow steps 21 - 

21) Log onto any workstation/server as the new user 

22) Right Click the My Computer icon and select Map Network Drive 
23) Specify the drive letter as G: 

24) Scroll down and find the RFMSS server and Double click it 
25) Double click the directory labeled G 

26) Double click the My Computer icon 
27) Double click the G: drive 
28) Double click the rfmss40 directory 
29) Locate the rfmssxxi icon 
30) Left Click and hold the rfmssxxi icon, drag it to the desktop and release 
31) Double click the rfmssxxi shortcut and verify that you can log onto RFMSS 
32) Log off the user 

33) Repeat steps 21 - 32 for all users in need of roaming profiles 
Appendix  B:  GIS Installation Troubleshooting



1) Dr. Watson Error occurs when opening the Project, before getting the Oracle Logon Screen 

2) Check to see if ODBC is installed correctly and that RFMSS40 has been designated as an ODBC 

database 

3) Can’t find $GISDATA… 



4) Check the WIN.INI file to make sure that the pointer to the RFMSS40.INI file is correct and uses drive notation and not network notation (should be g:\… and not \\server\…).

5) Check that the modified Arcview startup file was installed in the G:\ESRI\AV_GIS30\ARCVIEW\ETC directory 

6) Make sure that the SERVER_GIS entry in the RFMSS40.INI file points to the correct location of the GIS installation data 

7) Can’t find $LOCALGIS…



8) In addition to the steps for #2, check to see that the entry for LOCAL_GIS in the RFMSS40.INI file points to the location of the client GISDATA files 

9) Map appears correctly, but symbols on the legend and the display are lines and squiggles instead of the normal symbols 


                                        

Good and Bad Font Example

10) It is likely that the ESRI font files were not installed on the client machine.  Run the Setup application from the G:\ESRI\AV_GIS30\AVSETUP directory.  This is on the server 

11) Arcview opens, but does not open the Operations project (it just sits at a gray screen and does not request an ORACLE logon).  Check to see that the RFMSS40.INI file is correct.  The operations project should be designated as PROJ_1 and not PROJ_FD.  Check the path to the project 

12) Arcview does not open and a DOS window flashes on the screen.  This might be caused by the WIN.INI file being in an unusual location (i.e., not c:\WINNT or c:\WINDOWS).  This possible problem should have been corrected 

13) Dr. Watson Errors, other than #1 above.  We have had occasional trouble with these errors when Arcview attempts to retrieve information from an empty Oracle table.

14) The project starts to open, but you get the message that it can not find the dialog.avx file 



15) If you press cancel, and the project contains forms, the following error message will occur 



16) You get this error if the Patch to Arcview has not been installed.  Install the patch, following the instructions in this VDD in Section 5.0

Appendix  C:  Upgrade Instructions 

These are instructions for upgrading a system already using  version 3.0.

C.1

Database and Application Upgrade

Four (4) batch files on a CD will automatically handle a large part of the RFMSS upgrade.   It covers upgrading the back up database and application, the application upgrade, and GIS application upgrades such as replacing the avfiles folder, removing read-only attributes from the GIS files and replacing the startup file.  These instructions are to be performed on the RFMSS XXI NT server.

1) Have all users log out of RFMSS application.

2) Put the RFMSS server CD 4.0 in the CD-ROM drive F: (or whatever letter designates the CD-ROM drive).
3) Click Start> Program> Command prompt.  A DOS window is displayed.

4) In the DOS window at the prompt for the CD ROM drive, type, upgrade\app_upgrade\backup_old_version.
5) Press the Enter key.  Allow time for process to finish.

6) At the new DOS command prompt enter, upgrade\app_upgrade\del_old_version.
7) Press the Enter key.   

8) The system will ask for deletion verification at five different intervals.  On each occasion, enter Y for yes and press the Enter key.

9) At the new DOS command prompt enter, upgrade\app_upgrade\install_new_version.
10) The system will ask for deletion verification.  Enter Y for yes and press the Enter key.

11) At the new DOS command prompt enter, upgrade\app_upgrade\db_upgrade40.
12) A new DOS window will be displayed and prompt the user for a password.

13) Enter the database password for RFMSS.

14) Hit Enter.  When the SQL prompt appears, this window may be closed.

15) Open the error log.  If there are no errors, this  portion of the upgrade process is complete.  If there are errors, contact the RFMSS help desk.

C.2
GIS Updates 

The GIS Application should be upgraded only if the GIS application has already been installed and GIS data is loaded for the specific installation. GIS should be upgraded at a networked client which is currently running the upgraded RFMSS application. 

C.2.1
Update the rfmss40.ini file:

1) Click on the Start button on the task bar at bottom of screen.

2) Choose Run…

3) Enter Notepad.  Click OK.

4) In Notepad, choose File > Open.

5) In Files of Type, Choose All Files from drop-down list.

6) Navigate through open window to choose G:\rfmss40_backup30\rfmss40.ini file.

7) Click OK.
8) Use the scroll bar to find the lines in rfmss40.ini file that begin with these characters:

UTM_ZONE = 

MIL_GRID_PRE = 

DATUM =

9) Select these lines.  Choose Edit > Copy.

10) In Notepad, choose File > Open.

11) Navigate through open window to choose G:\rfmss40\rfmss40.ini file.

12) Find the lines in rfmss40.ini file that begin with these characters:

UTM_ZONE = 

MIL_GRID_PRE = 

DATUM =

13) Select these lines.  Choose Edit > Paste.  The values from the previous version of RFMSS XXI should now be in these lines.

14) Choose File > Save.

15) Choose File>Close.

NOTE: All current users must replace their C:\gisdata folder with the G:\gisdata folder 

C.2.2
Setting Up the Layers in the GIS Application.

Follow the attached instructions, How to Setup Operations (C.3) and How to Setup MIMs (C.4).

C.2.3
Errors upon running projects

Consult the VDD for known GIS errors.  Make sure that the ODBC driver is set up for every userid that logs onto the Windows NT and that the rfmss40.ini file is edited correctly (see VDD).

C.3 
HOW TO SETUP OPERATIONS

1) Log on to the RFMSS XXI application.

2) Click Operations > Firing Desk (Graphic Mode).

3) Log on to Oracle as RFMSS/RFMSS21.

4) A blank map will appear.

5) Click on the Join button 

 to setup layers (located at the top right of the screen).

6) A window will appear, it will say: Select Datasets to Add, select Installation Boundary, click OK.

7) A second window will appear, it says: Add Theme for Installation Boundary.  The layer you will add will be called boundary.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find boundary.shp located there.  Select it, click OK.

8) A third window will appear, it will ask you to: Select Field Containing Facility ID data for Installation Boundary.  Select Fac_id, click OK.

9) The correct layer will be added to the legend.  Turn on the layer, if it shows up on the map display go to step 10.  If not, highlight the Installation Boundary layer in the legend, click the GIS Options menu > Remove Layers, click yes.  Repeat steps 5 - 9.

10) Click the Join button 

 to setup layers.

11) A window will appear, it will say: Select Datasets to Add, select Training Area Status, click OK.

12) A second window will appear, it says: Add Theme for Training Area Status.  The layer you will add will be called boundary.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find boundary.shp located there.  Select it, click OK.

13) A third window will appear, it will ask you to: Select Field Containing Facility ID data for Training Area Status.  Select Fac_id, click OK.

14) The correct layer will be added to the legend.  Turn on the layer, if it shows up on the map display go to Step 15.  If not, highlight the Training Area Status layer in the legend, click the GIS Options menu > Remove Layers, click yes.  Repeat steps 10 - 14.

15) Click the Join button 

 to setup layers.

16) A window will appear, it will say: Select Datasets to Add, select Firing Ranges, click OK.

17) A second window will appear, it says: Add Theme for Firing Ranges.  The layer you will add will  be called range.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find range.shp located there.  Select it, click OK.

18) A Third window will appear, it will ask you to: Select Field Containing Facility ID data for Firing Ranges.  Select Fac_id, click OK.

19) The correct layer will be added to the legend.  Turn on the layer, if it shows up on the map display go to Step 20.  If not, highlight the Firing Ranges layer in the legend, click the GIS Options menu > Remove Layers, click yes.  Repeat Steps 15 - 19.

20) Click the Join button 

 to setup layers.

21) A window will appear, it will say: Select Datasets to Add, select Drop Zones, click OK.

22) A second window will appear, it says: Add Theme for Drop Zones.  The layer you will add will be called dropzone.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find dropzone.shp located there.  Select it, click OK.

23) A third window will appear, it will ask you to: Select Field Containing Facility ID data for Drop Zones.  Select Fac_id, click OK.

24) The correct layer will be added to the legend.  Turn on the layer, if it shows up on the map display go to Step 25.  If not, highlight the Drop Zones layer in the legend, click the GIS Options menu > Remove Layers, click yes.  Repeat steps 20 - 24.

25) Click the Join button 

 to setup layers.

26) A window will appear, it will say: Select Datasets to Add, select Observation Points, click OK.

27) A second window will appear, it says: Add Theme for Observation Points.  The layer you will add will be called observation.shp navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find observation.shp located there.  Select it, click OK.

28) A third window will appear, it will ask you to: Select Field Containing Facility ID data for  Observation Points.  Select Fac_id, click OK.

29) The Correct layer will be added to the legend.  Turn on the layer, if it shows up on the map display go to Step 30.  If not, highlight the Observation Points layer in the legend, click the GIS Options menu > Remove Layers, click yes.  Repeat steps 25 - 29.

30) Click the Join button 

 to setup layers.

31) A window will appear, it will say: Select Datasets to Add, select Scheduled SDZ’s, click OK.

32) A second window will appear, it says: Add Theme for Scheduled SDZ’s.  The layer you will add will be called sdzs.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find sdzs.shp located there.  Select it, click OK.

33) A third window will appear, it will ask you to: Select Field Containing Facility ID data for Scheduled SDZ’s.  Select Fac_id click OK.

34) The correct layer will be added to the legend.  Turn on the layer, if it shows up on the map display go to Step 35.  If not, highlight the Scheduled SDZ’s layer in the legend, click the GIS Options menu > Remove Layers, click yes.  Repeat steps 30 - 34.

35) Click the Join button 

 to setup layers.

36) A window will appear, it will say: Select Datasets to Add, select Standard SDZ’s, click OK.

37) A second window will appear, it says: Add Theme for Standard SDZ’s.  The layer you will add will be called sdzs.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find sdzs.shp located there.  Select it, click OK.

38) A third window will appear, it will ask you to: Select Field Containing Facility ID data for Standard SDZ’s.  Select Fac_id, click OK.

39) The correct layer will be added to the legend.  Turn on the layer, if it shows up on the map display go to Step 40.  If not, highlight the Standard SDZ’slayer in the legend, click the GIS Options menu > Remove Layers, click yes.  Repeat steps 35 - 39.

40) Now that all layers have been added, turn off the Standard SDZ’s layer.

41) To label, highlight each layer in the legend and click the Labeler button 

 (located at the top right of the screen, next to the Join button.  It has an arrow with the letters ABC over the top of it).

42) If you want to delete any labels, click the Pointer button 

  (looks like an arrow) and then click on a label (a label is selected when there are four boxes placed around it).  To select multiple labels, hold the Shift key while clicking.  Click the Setup Activities menu and select Delete Graphics.

43) You will NOT have to add layers to the Installation Boundary layer.

44) If you want to resize your labels, click the Pointer button 

 and select any label.  Click on one of the four boxes and drag it to the desired size.

45) If you want to change the placement of your labels, click the Pointer button 

 and select any label. Place the cursor inside the four boxes until the Plus Sign cursor appears and then drag it to the desired location.

46) See the next page for correct legend order.

47) Click the GIS Options menu and select Save Current Configuration, then exit the project.   

48) OPERATIONS LEGEND:

      


C.4

HOW TO SETUP MIMS

1) Log on to the RFMSS XXI application.

2) Click on ITAMS > MIMs > MIMs Map.

3) Log on to Oracle as RFMSS/RFMSS21.

4) The MIMs.apr shell appears blank.

5) Click on minimize button ( 

 ) of Installation Map window.

6) Click on the header of the MIMS.apr project window.

7) Select the Tables icon in left-hand window.

8) Select Facility table in right-hand window.

9) Click the Open button.

10) Choose the Table > Refresh menu item at top of screen.  The screen should fill with data.

11) Click on the header of the Facility table window (blue bar along top) and drag window to right side of screen (to an accessible place).

12) Select GIS_MIMS table in right-hand window of MIMS.apr project window.

13) Click the Open button.

14) Select the FAC_ID column heading in GIS_MIMS table window.  The column heading should turn dark.

15) Select the header of the Facility table.

16) Select the FAC_ID column heading in Facility table window.  The column heading should turn dark.

17) Select Table > Join menu item from menu at top of screen. (GIS_MIMS table window should disappear.  Last two columns in Facility table should be TOTAL_PROJ_MIMS and TOTAL_ACTUAL_MIMS.  Click on scrollbar along bottom of window to see columns on far right.)

18) Close Facility table by clicking the X box in corner (

).

19) Choose File > Save Project menu item from the menu.

20) Click Maximize button (

 )on the Installation Map window in lower left hand corner 

21) The MIMs.apr shell appears blank

22) Click on the Join button 

 in the top row.

23) A window will appear, it will say: Select Datasets to Add, select Installation Boundary, click OK.

24) A second window will appear, it says: Add Theme for Installation Boundary.  The theme you will add will be called boundary.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find boundary.shp there.  Select it, click OK.

25) A third window appears, it will ask you to: Select Field Containing Facility ID data for Installation Boundary.  Select Fac_id, click OK.

26) The correct layer will be added to the legend.

27) Click on the Join button 

 in the top row.

28) A window will appear, it will say: Select Datasets to Add, select Projected MIMs Status, click OK.

29) A second window will appear, it says: Add Theme for Projected MIMs Status.  The theme you will add will be called boundary.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find boundary.shp there.  Select it, click OK.

30) A third window will appear, it will ask you to: Select Field Containing Facility ID data for Projected MIMs Status.  Select Fac_id, click OK.

31) The correct layer will be added to the legend.

32) Click on the Join button 

 in the top row.

33) A window will appear, it will say: Select Datasets to Add, select Actual MIMs Status, click OK.

34) A second window will appear, it says: Add Theme for Actual MIMs Status.  The theme you will add will be called boundary.shp, navigate to your G:\ESRI\Avfiles\Ftgisdat folder, you will find boundary.shp there.  Select it, click OK.

35) A third window will appear, it will ask you to: Select Field Containing Facility ID data for Actual MIMs Status.  Select Fac_id, click OK.

36) The correct layer will be added to the legend.

37) When all three layers are added, you will need to label them.

38) Highlight the first layer, Actual MIMs Status, click the Labeler button 

, in the top row, next to the Join button 

.  (The Labeler button has an arrow and the letters ABC over the top of it)

39) This will attach labels to the map display.

40) Highlight the second layer, Projected MIMs Status, click the Labeler button 

.

41) This will attach labels to the map display.

42) You will NOT have to add labels to the Installation Boundary layer.

43) If you want to delete any labels, click the Pointer button 

  and then click on a label (a label is selected when there are four boxes placed around it).  To select multiple labels, hold the Shift key while clicking.  Next, click the Setup Activities menu and select Delete Graphics.

44) If you want to resize your labels, click the Pointer button 

 and select any label.  Click on one of the four boxes and drag it to the desired size.

45) If you want to change the placement of your labels, click the Pointer button 

 and select any label.  Place the cursor inside the four boxes until the Plus Sign cursor appears and then drag it to the desired location.

46) The correct legend order is shown below.

47) Click the GIS Options menu and select Save Current Configuration, then exit the project.

MIMS LEGEND:




Appendix  D:  RFMSS Training Database VDD

This document describes step-by-step the procedures required to install, activate, and deactivate the Training database.  Once the Training Database is installed, it is activated for the trainer.  The trainer is expected to do the mapping (included) to the appropriate Oracle instance and GIS files.  The trainer is expected to return the user’s PC to its original state after training.  At this point the Training Database ought to be deactivated.

Also, a site, at its own discretion, may request the reactivation of the Training Database for a certain period of time. The maintenance required for the Training Database consists of updates as the application is updated, no periodical backup is needed. If it gets corrupted it may be reinstalled with the data that has gone through the CM process.  No permanent data should be stored in the Training Database.

WARNING: RT00 must be in upper case throughout the installation.  Problems may arise if there are inconsistencies, especially in relation to LISTENER.ORA.

D.1 INSTALL TRAINING DATABASE ON THE SERVER

The application must be in working condition before initiating any work for the training database.  Please check.  Also heed the warning about putting rt00 in upper case.

D.1.1   GET TRAINING SOFTWARE BACKUP INTO THE SERVER

Get administrator privilege on the server and drive where the Training Database will be stored.  You must also have appropriate privileges to start and stop Oracle instances. The drive ought to be the M: drive but if it is not then replace M with the appropriate location name (which may include more than a new drive name).   M: or an equivalent location must have a minimum of 600 MB of free space fully accessible for reading, writing, and sharing.

COPY FILES.  Copy from CD and paste on appropriate drive.  The assumption is that the training drive is  the M: drive.  There are numerous ways to copy the folders; one method is given below.

1) Double click  My Computer

2) Double click  Z:
 Z: drive is the CD drive.

3) Drag folder ORANT to the M: drive. 

4) Drag folder TRAINING to the M: drive. 

5) Once system is done copying close the windows that have been opened. 

IF NOT USING M: DRIVE EDIT INITRT00.ORA.  Edit, using Notepad, M:\ORANT\DATABASE\ INITRT00.ORA for the correct drive at two locations. The two ‘Control_files’ should be on the appropriate drive. 

1) Select Start.

2) Select Programs. 

3) Select Accessories. 

4) Select Notepad.

5) Select File.

6) Select Open.

7) Click on the entry for ‘The Files of type:’ which states ‘Text Documents’ then click on
‘All Files (*.*)’ .

8) Click in ‘Look in’ entry and go through the selection process until you have chosen

M:\ORANT\DATABASE\ INITRT00.ORA .

9) Find the two ‘Control_files’ and correct to the appropriate drive.

PROVIDE SHARING TO TRAINING AREA.  

WARNING: The M: drive has been identified as TRAINING in the sharing process.  It needs to be made ‘Not shared’ or have a different name.  Folder ‘TRAINING’ must be shared with identification as ‘TRAINING’. The way to accomplish this is given below. 

1) Select Start.

2) Select Programs.

3) Select Windows NT Explorer.

4) Right mouse button click on M: 

5) Click Sharing.

6) Select  Not Shared.  This radio button is under the Sharing tab.  This will make M: as not 
shared.  If M: is already not shared then there is no change.

7) Click Yes.

8) Click OK.

9) Double click M:
 This will display the folders under the M: drive.

10) Right mouse button click on M:Training.  Right click the TRAINING folder.

11) Click Sharing.

12) Click Shared As  radio button.

13) Select Share Name training.   The default fill may automatically be correct.

14) If files are compressed or have that option, then decompress them.

15) Select Permissions.

16) Give ‘full privilege’ access (this is an option) to administrator and RFMSS group.   If a RFMSS group is not defined then give the privilege to ‘Everyone’. 

17) Click OK.

18) Click OK.

19) Click File.

20) Click Close.

D.1.2.  CREATE DATABASE INSTANCE ON THE SERVER

1) Select Start.

2) Select Programs.

3) Select Oracle for Windows NT.

4) Select NT Instance Manager.

5) Select New.

6) Select SID: rt00.  Use this name only.

7) DBA Authorization Password: training.  Please do not use another password.

8) Confirm Password: training.
9) Check that Services and Instance radio buttons are on, if not, click them on.

10) Instance Start up Mode:  Automatic.

11) Parameter Initialization Filename: M:\orant\database\initrt00.ora
12) Select Advanced.

13) Database:  RT00.

14) Logfile:  correct in two locations on the same line.  Change the H: drive to M: drive and eliminate \COTS so the following will be the entry on a single line (lower case entry is acceptable):  ‘M:\ORANT\DATABASE\LOG1RT00.ORA’ SIZE 200K, ‘M:\ORANT\DATABASE\LOG2RT00.ORA’ SIZE 200K 

15) Do not change any other information on that line, such as keep the single quotes where they are. 

16) Datafile: Change location and size to 50M to become (lower case entry is acceptable): 
‘M:\orant\DATABASE\SYSRT00.ORA’ SIZE 50M. 

17) Click OK.

18) Click OK.  On OK there is a long message stating,  Password file created…

19) Click OK.  A message of please wait … is displayed.  There is a waiting period before coming back.

20) Click OK.  For run script.

21) Click Close.

D.1.3.
SET UP & GET IP ADDRESS

Steps 5 through 10 assumes that the RFMSS application is installed otherwise they will not furnish the Host name.  You need the server Host name to be able to proceed.  It is recommended that the Training Database be installed after the RFMSS application.

1) Select Start.
2) Select Programs.

3) Select Oracle for Windows NT.

4) Select SQL*Net Easy Configuration.

5) Select View Configuration Information.

6) Click OK.

7) Select RFMSS40.   If RFMS is an option then pick it instead of RFMSS40.

8) Click OK.

9) Write down host name (e.g., FS7-5800), where Protocol is TCP/IP, and database is rfms. 

10) Click OK.

11) Add Database Alias.

12) Click OK.

13) Database Alias:  RT00.
14) Click OK.

15) Select TCP/IP.  Usually this radio button is already on.

16) Click OK.

17) Enter host name copied earlier (e.g., FS7-5800).

18) Database Instance: RT00.
19) Click OK.

20) Click Yes.

21) Exit SQL*Net Easy Configuration.

22) Click OK.

23) Click OK.

D.1.4.
START INSTANCE

It is assumed that LISTENER.ORA file has been updated when the application was installed.  Appendix A shows how to update LISTENER.ORA if it has not been done yet. 

1) Wait twenty minutes to start the next three steps or repeat them until the condition in step 3 is met. Access the file 
H:\COTS\ORANT\DATABASE\CREATE.LOG 

2) with the NOTEPAD or equivalent program. >

3) Scroll to the end of the file (one way is to drag the relative-location-block on the right side from being next to the up arrow to next to the down arrow).

4) If last line is:  SVRMGR> spool off

5) Then go to step 6 otherwise close the file and go back to step 1. 

It is extremely important that the condition in step 3) is met before proceeding because Oracle must finish running a background process first. 

6) Restart the server to restart the Oracle listener and to start the RT00 instance.

D.1.5.
ADD TABLESPACES AND ROLL BACK AREA TO DATABASE

1) Select Start.  Log on to SQLPLUS and run two routines.

2) Select Programs.

3) Select Oracle for Windows NT.

4) Select SQLPlus.

5) If an error is displayed after pressing the Enter key at the end of step 8, try running SQLPLUS again from step 1.  Oracle may still be in the process of activating its background processes. 

6) At the prompt, enter System.
Entry for user ID.

7) At the prompt, enter Manager. Entry for password.

8) At the prompt, enter RT00 Host_string.

9) At the prompt, enter @M:\orant\database\crt_ts_r.sql

10) Enter value for folder: M:\orant\database
11) Check to make sure that there are no errors, otherwise something needs to be fixed.

12) At the prompt, enter @M:\ orant\database \pupbld.sql.
Ignore errors generated here. 

13) Enter exit.
D.1.6.  IMPORT TRAINING DATABASE DATA AND ACCOUNTS

1) Go to DOS level.  

2) Enter Start

3) Enter Programs

4) Enter MS DOS Prompt

5) Enter set oracle_sid=RT00.
No spaces around = sign.

6) imp73  system/manager
7) file : m:\orant\database\exp00.dmp
8) Take your time in answering the questions especially for the following questions.  Accept default by pressing the Enter key for the questions without a bolded letter.  Answer with a single letter as shown below.   The process will take a while.

9) Enter insert buffer size (30720).  Accept default.

10) List content of import file only  (n) . Accept default.

11) Ignore Create Error due to object existence (n).  Enter y only.

12) Import grant (y). Accept default.

13) Import table data (y).   Accept default.

14) Import Entire export file (n).  Enter y only.

15) Wait until the process of importing the database is over.

16) Select Exit to exit DOS.

CHECK ON IMPORT FUNCTION
1) Select Start


! Log on to SQL*PLUS and run CHECK.SQL routine.

2) Select Programs
3) Select Oracle for Windows NT
4) Select SQLPlus

5) Enter System.  User Name.

6) Enter Manager.
 Password.

7) Enter RT00.  Host String.
8) Enter  @M:\orant\database\check.sql
This will run a SQL program.  The result should be 40 users and 257 tables. 

9) Enter exit.
The installation of the RFMSS Training Database is complete.

D.2  MAP TRAINING DATABASE ON CLIENT WORKSTATION

The application must be in working condition before initiating any work for the training database.  Please check.  Also heed the warning about putting RT00 in upper case.

D.2.1.  DELETE RFMSS ICON

1)
Right mouse button click on RFMSS icon.

2)
Select Delete.

3)
Select Yes.

D.2.2.  CHANGE G: DRIVE MAPPING AND COPY NAME OF ORIGINAL MAP

1) Select Start.

2) Select Programs.

3) Select Windows NT Explorer.  If on Windows 95 then click Windows Explorer.

4) Select Tools.

5) Write down path name associated with G: for reuse after training is over.  Path name has server name as part of  it. 

6) Select Disconnect Network Drive.

7) Select G:

8) Click  OK.

9) Click Tools.

10) Click Map Network Drive.

11) Select G:  You must choose the G: drive.

12) Select Training.  In the path option select ‘training’.  You may have to enter \\server_name\training manually.

13) Click on for ’Reconnect at logon’ or the mapping is lost after log off.

14) Click OK.

15) Select File.

16) Select Close.

D.2.3.  MAP TO ORACLE INSTANCE FOR TRAINING

1)
Select Start.

2)
Select Programs.

3)
Select Oracle for Windows NT

! ‘NT’ may be ‘95’.

4)
Select SQL*Net Easy Configuration.

5)
Select Modify.

6)
Click OK.

7)
Select RFMSS40.

8)
Click OK.
9)
Select TCP/IP.

10)
Click OK.
11)
Change only the ‘Database Instance’ to: RT00 .  Remember upper case.

12)
Click OK.

13)
Confirm Modifying Database Alias  Yes.

14)
Exit SQL*Net Easy configuration.  Click on this radio button.

15)
Click OK.  Notification.

16)
Click OK.

D.2.4.  CREATE NEW ICON AND CHANGE ICON NAME

Changing icon name may be done in many ways.  The importance of changing the text associated with the icon is to keep the user aware of the database instance they are accessing.

1)
Double click  My Computer.
2)
Double click  G:

3)
Double click  Rfmss40.
4)
Drag Rfmssxxi.exe as new icon into the Desk Top area.

5)
Close windows.

6)
Click on the text ‘Shortcut to Rfmssxxi’.  Click again on text to change it.

7)
Change the words to read Rfmss Training.

8)
Test to confirm that the Training Database is fully functioning for text and graphics. 

D.3  DEACTIVATE TRAINING INSTANCE

D.3.1.  MAKE ‘START UP FOR TRAINING DATABASE INSTANCE’ MANUAL

1)
Select Start.

2)
Select Programs.

3)
Select Oracle for Windows NT.

4)
Select NT Instance Manager.
5)
Select RT00.
 (Click on RT00 instance.)

6)
Select Edit.

7)
Select Instance Start Up Mode.

8)
Select Manual.   Change from automatic to manual.

9)
Click OK.

10)
Click OK.

11)
Click OK.    Wait until process is complete. 

12)
Click OK.

13)
Click Close.
D.3.2  STOP TRAINING DATABASE INSTANCE

1)
Select Start.

2)
Select Settings.

3)
Select Control Panel.

4)
Double click  Services.

5)
Select ORACLESTARTRT00.   Select item.

6)
Select Stop.

7)
Select Oracle TNS Listener.  Steps to stop listening for RT00.

WARNING:  The action below will stop all Oracle instances on the server.   Take appropriate steps. 

8)
Select Stop.

9)
Select Start.

10)
Select Close.
D.4  MAP OPERATIONAL SYSTEM ON CLIENT WORKSTATION

 D.4.1  DELETE RFMSS ICON

1)
Right mouse button click on RFMSS. Right Click RFMSS icon.

2)
Select Delete.

3)
Select Yes.

 D.4.2  CHANGE G: DRIVE MAPPING AND USE NAME OF ORIGINAL MAP

1)
Select Start.

2)
Select Programs.

3)
Select Windows NT Explorer.  If Windows 95 then click Windows Explorer. 

4)
Select Tools.

5)
Select Disconnect Network Drive.

6)
Select G:

7)
Click OK.

8)
Select Tools.

9)
Select Map Network Drive.

10)
Select G:  You must choose the G: drive.

11)
Select in PATH the path name copied earlier.  Reconnect at logon must be on.

12)
Click OK.

13)
Select File.

14)
Select Close.

D.4.3  MAP TO WORKING ORACLE INSTANCE 

1)
Select Start.

2)
Select Programs.

3)
Select Oracle for Windows NT.
‘NT’ may be ‘95’.

4)
Select SQL*Net Easy Configuration.

5)
Select Modify.

6)
Click OK.

7)
Select  RFMSS40.

8)
Click OK.

9)
Select TCP/IP.

10)
Click OK.
11)
Change the ‘Database Instance’ to: rfms only. > 

12)
Click OK.

13)
Confirm Modifying Database Alias  Yes

14)
Exit SQL*Net Easy configuration.
Click on this radio button.

15)
Click OK.  Notification.

16)
Click OK.
D.4.4  CREATE NEW ICON

1)
Double click  My Computer.
2)
Double click  G:
3)
Double click  Rfmss40.
4)
Drag Rfmssxxi.exe as new icon into the Desk Top area. 

5)
Close windows. 

6)
Test the application to make sure that the mapping is correct for text and graphics. 

D.5 REACTIVATE TRAINING DATABASE ON THE SERVER

D.5.1.  MAKE ‘START UP FOR TRAINING DATABASE INSTANCE’ AUTOMATIC

1)
Select Start.

2)
Select Programs.

3)
Select Oracle for Windows NT.

4)
Select NT Instance Manager.
5)
Select RT00.  Click on RT00 instance.

6)
Select Edit.

7)
Select Instance Start Up Mode.
8)
Select Automatic.
  Change from automatic to manual.

9)
Click OK.

10)
Click OK.

11)
Click OK.      Wait until done. 

12)
Click OK.

13)
Select Close.
D.5.2.  START TRAINING DATABASE INSTANCE

1)
Select Start.

2)
Select Settings.

3)
Select Control Panel.

4)
Double click  Services.
5)
Select ORACLESTARTRT00.
Select item.

6)
Select Start.

7)
Select Oracle TNS Listener.
Steps to stop listening for RT00 .

WARNING:  The action below will stop all Oracle instances on the server.  Take appropriate steps. 

8)
Select Stop.

9)
Select Start.

10)
Select Close.
D.6  UPDATE TO LISTENER.ORA

If database instance RT00 is not being recognized you may need to check LISTENER.ORA and make sure that it has been added.  LISTENER.ORA is the cause of many problems.  Please make a second copy of the file and be careful in following the steps below.

1)
Using Start    Find   locate LISTENER.ORA (usually on H: drive). 

2)
Copy LISTENER.ORA to LISTENER.OLD.   
3)
With Notepad or WORDPAD open.

4)
...\ORANT\NETWORK\ADMIN\LISTENER.ORA.

5)
Find the paragraph below.  Do not delete or replace ORCL. 



    (SID_DESC =



      (SID_NAME = ORCL)




    )

6)
Copy the three lines displayed above then paste them right below them. 

7)    Change the second ORCL to RT00 .   So the SID_LIST_LISTENER  section will probably be as shown below



SID_LIST_LISTENER =



  (SID_LIST =



    (SID_DESC =



      (SID_NAME = ORCL)




    )



    (SID_DESC =



      (SID_NAME = RT00)




    )



  )

There may be other SID_NAMES (i.e., sets of three lines) defined between the last two parentheses )  or after the SID_LIST line; KEEP THEM THERE.  The last parenthesis  is shown just to confirm that it is not deleted.  Spaces before and after the = sign are important.  The copy-and-paste process hopefully reduces the possibility of error. 

8) 
Find the place holders for host name and server name and change them to the appropriate name.  The default name is usually FS7NNNN.  You can find them by looking for host  and by looking for server . 

9)
Save and Exit. 

10)
Return to section 1.4. step 2) and continue from there. 

Appendix  E:  Access to User Manual Softcopy

A softcopy of the RFMSS XXI User Guide, version 4.0 is provided on the RFMSS Server CD.

To access the guide:

1) Put the RFMSS Server 4.0 CD in the CD-ROM drive F: (or whatever letter designates the CD-ROM drive).

2) Double click on My Computer

3) Double click on the CD-ROM drive

4) Double click on the folder, user_manual.  The files are named after the main menu headings.  

5) Double click the desired file.
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